initial commit
This commit is contained in:
parent
4137e7f7db
commit
4630e6e462
3 changed files with 25 additions and 24 deletions
30
.SRCINFO
30
.SRCINFO
|
@ -5,32 +5,34 @@ pkgbase = edgetx-companion
|
||||||
url = https://edgetx.org/
|
url = https://edgetx.org/
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
license = GPL-2.0
|
license = GPL-2.0
|
||||||
makedepends = cmake
|
makedepends = arm-none-eabi-binutils
|
||||||
makedepends = gcc
|
makedepends = arm-none-eabi-gcc
|
||||||
makedepends = git
|
makedepends = arm-none-eabi-newlib
|
||||||
makedepends = xsd
|
|
||||||
makedepends = bc
|
|
||||||
makedepends = python
|
|
||||||
makedepends = avr-gcc
|
makedepends = avr-gcc
|
||||||
makedepends = avr-libc
|
makedepends = avr-libc
|
||||||
makedepends = sed
|
makedepends = bc
|
||||||
makedepends = qt5-tools
|
makedepends = cmake
|
||||||
makedepends = python-pyqt5
|
|
||||||
makedepends = arm-none-eabi-gcc
|
|
||||||
makedepends = arm-none-eabi-binutils
|
|
||||||
makedepends = arm-none-eabi-newlib
|
|
||||||
makedepends = fox
|
makedepends = fox
|
||||||
|
makedepends = gcc
|
||||||
|
makedepends = git
|
||||||
|
makedepends = python
|
||||||
makedepends = python-pillow
|
makedepends = python-pillow
|
||||||
|
makedepends = python-pyqt5
|
||||||
|
makedepends = qt5-svg
|
||||||
|
makedepends = qt5-tools
|
||||||
|
makedepends = qt5-translations
|
||||||
|
makedepends = sed
|
||||||
|
makedepends = xsd
|
||||||
|
depends = hicolor-icon-theme
|
||||||
depends = qt5-base
|
depends = qt5-base
|
||||||
depends = qt5-multimedia
|
depends = qt5-multimedia
|
||||||
depends = sdl
|
depends = sdl
|
||||||
depends = hicolor-icon-theme
|
|
||||||
optdepends = dfu-util: tool for flashing stm32 based radios
|
optdepends = dfu-util: tool for flashing stm32 based radios
|
||||||
provides = companion
|
provides = companion
|
||||||
conflicts = companion
|
conflicts = companion
|
||||||
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.5.0
|
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.5.0
|
||||||
source = install.patch
|
source = install.patch
|
||||||
sha256sums = SKIP
|
sha256sums = SKIP
|
||||||
sha256sums = f156dfd0800251ea78ff01fb32704e5a5a826360d3f2da57b7d877521ba61a45
|
sha256sums = 36bf7c59adfe9221f8b03809e0ca0dc537328e239b2384829fb17290137e5005
|
||||||
|
|
||||||
pkgname = edgetx-companion
|
pkgname = edgetx-companion
|
||||||
|
|
6
PKGBUILD
6
PKGBUILD
|
@ -12,9 +12,9 @@ pkgdesc="EEPROM Editor for EdgeTX RC transmitter firmwares"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://edgetx.org/'
|
url='https://edgetx.org/'
|
||||||
license=('GPL-2.0')
|
license=('GPL-2.0')
|
||||||
depends=('qt5-base' 'qt5-multimedia' 'sdl' 'hicolor-icon-theme')
|
depends=('hicolor-icon-theme' 'qt5-base' 'qt5-multimedia' 'sdl')
|
||||||
optdepends=('dfu-util: tool for flashing stm32 based radios')
|
optdepends=('dfu-util: tool for flashing stm32 based radios')
|
||||||
makedepends=('cmake' 'gcc' 'git' 'xsd' 'bc' 'python' 'avr-gcc' 'avr-libc' 'sed' 'qt5-tools' 'python-pyqt5' 'arm-none-eabi-gcc' 'arm-none-eabi-binutils' 'arm-none-eabi-newlib' 'fox' 'python-pillow')
|
makedepends=('arm-none-eabi-binutils' 'arm-none-eabi-gcc' 'arm-none-eabi-newlib' 'avr-gcc' 'avr-libc' 'bc' 'cmake' 'fox' 'gcc' 'git' 'python' 'python-pillow' 'python-pyqt5' 'qt5-svg' 'qt5-tools' 'qt5-translations' 'sed' 'xsd')
|
||||||
provides=('companion')
|
provides=('companion')
|
||||||
conflicts=('companion')
|
conflicts=('companion')
|
||||||
source=("git+https://github.com/EdgeTX/edgetx.git#tag=v${pkgver}"
|
source=("git+https://github.com/EdgeTX/edgetx.git#tag=v${pkgver}"
|
||||||
|
@ -22,7 +22,7 @@ source=("git+https://github.com/EdgeTX/edgetx.git#tag=v${pkgver}"
|
||||||
|
|
||||||
)
|
)
|
||||||
sha256sums=('SKIP'
|
sha256sums=('SKIP'
|
||||||
'f156dfd0800251ea78ff01fb32704e5a5a826360d3f2da57b7d877521ba61a45')
|
'36bf7c59adfe9221f8b03809e0ca0dc537328e239b2384829fb17290137e5005')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${_pkgbase}
|
cd ${_pkgbase}
|
||||||
|
|
|
@ -1,16 +1,15 @@
|
||||||
@@ -4,7 +4,10 @@
|
@@ -4,7 +4,9 @@
|
||||||
set -e
|
set -e
|
||||||
set -x
|
set -x
|
||||||
|
|
||||||
-if [ "$(uname)" = "Darwin" ]; then
|
-if [ "$(uname)" = "Darwin" ]; then
|
||||||
+if [[ ! -z "MAKEFLAGS" ]]
|
+if [[ ! -z "MAKEFLAGS" ]]; then
|
||||||
+then
|
+ JOBS="${MAKEFLAGS:2}"
|
||||||
+ JOBS="${MAKEFLAGS:2}"
|
|
||||||
+elif [ "$(uname)" = "Darwin" ]; then
|
+elif [ "$(uname)" = "Darwin" ]; then
|
||||||
num_cpus=$(sysctl -n hw.ncpu)
|
num_cpus=$(sysctl -n hw.ncpu)
|
||||||
: "${JOBS:=$num_cpus}"
|
: "${JOBS:=$num_cpus}"
|
||||||
else
|
else
|
||||||
@@ -30,7 +33,7 @@
|
@@ -30,7 +32,7 @@
|
||||||
SRCDIR=$1
|
SRCDIR=$1
|
||||||
OUTDIR=$2
|
OUTDIR=$2
|
||||||
|
|
||||||
|
@ -19,7 +18,7 @@
|
||||||
if [ "$(uname)" = "Darwin" ]; then
|
if [ "$(uname)" = "Darwin" ]; then
|
||||||
COMMON_OPTIONS="${COMMON_OPTIONS} -DCMAKE_OSX_DEPLOYMENT_TARGET='10.9'"
|
COMMON_OPTIONS="${COMMON_OPTIONS} -DCMAKE_OSX_DEPLOYMENT_TARGET='10.9'"
|
||||||
elif [ "$(uname)" != "Linux" ]; then
|
elif [ "$(uname)" != "Linux" ]; then
|
||||||
@@ -41,9 +44,9 @@
|
@@ -41,9 +43,9 @@
|
||||||
COMMON_OPTIONS="${COMMON_OPTIONS} -DVERSION_SUFFIX=$3"
|
COMMON_OPTIONS="${COMMON_OPTIONS} -DVERSION_SUFFIX=$3"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -32,7 +31,7 @@
|
||||||
|
|
||||||
cmake ${COMMON_OPTIONS} -DPCB=X9LITE ${SRCDIR}
|
cmake ${COMMON_OPTIONS} -DPCB=X9LITE ${SRCDIR}
|
||||||
make -j${JOBS} libsimulator
|
make -j${JOBS} libsimulator
|
||||||
@@ -128,13 +131,3 @@
|
@@ -128,13 +130,3 @@
|
||||||
cmake ${COMMON_OPTIONS} -DPCB=X12S ${SRCDIR}
|
cmake ${COMMON_OPTIONS} -DPCB=X12S ${SRCDIR}
|
||||||
make -j${JOBS} libsimulator
|
make -j${JOBS} libsimulator
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue