upstream release 2.9.2
This commit is contained in:
parent
cfd3ae7595
commit
5e9eb3c390
3 changed files with 37 additions and 10 deletions
6
.SRCINFO
6
.SRCINFO
|
@ -1,6 +1,6 @@
|
|||
pkgbase = edgetx-companion
|
||||
pkgdesc = EEPROM Editor and Simulator for EdgeTX RC radio transmitter firmwares
|
||||
pkgver = 2.9.1
|
||||
pkgver = 2.9.2
|
||||
pkgrel = 1
|
||||
url = https://edgetx.org/
|
||||
arch = x86_64
|
||||
|
@ -36,7 +36,7 @@ pkgbase = edgetx-companion
|
|||
provides = companion
|
||||
conflicts = companion
|
||||
options = !debug
|
||||
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.9.1
|
||||
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.9.2
|
||||
source = git+https://github.com/jbeder/yaml-cpp.git
|
||||
source = git+https://github.com/raphaelcoeffic/AccessDenied.git
|
||||
source = git+https://github.com/FreeRTOS/FreeRTOS-Kernel.git
|
||||
|
@ -46,6 +46,7 @@ pkgbase = edgetx-companion
|
|||
source = git+https://github.com/EdgeTX/lvgl.git
|
||||
source = git+https://github.com/nothings/stb.git
|
||||
source = install.patch
|
||||
source = remove-ssl-check.patch
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
|
@ -56,5 +57,6 @@ pkgbase = edgetx-companion
|
|||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = 2f2d110ba03c3d852bec93a0705570df93e72f5e3757bd64494083c5a1ae59c5228024fca563043c05014b1962ccde88e029a6bac2fe36be6e852a53b35a43fb
|
||||
b2sums = 6ad8cfff9f623c1d0182713839419b633f421e762d01cd46b2ce817c1552929d9ffadcb38f112d6ac9d3d196346b781d842ad0d9c34d4dbe0d5709a3edbc6026
|
||||
|
||||
pkgname = edgetx-companion
|
||||
|
|
12
PKGBUILD
12
PKGBUILD
|
@ -4,7 +4,7 @@
|
|||
# Contributer: Arnaud
|
||||
|
||||
pkgname=edgetx-companion
|
||||
pkgver=2.9.1
|
||||
pkgver=2.9.2
|
||||
pkgrel=1
|
||||
pkgdesc="EEPROM Editor and Simulator for EdgeTX RC radio transmitter firmwares"
|
||||
arch=('x86_64')
|
||||
|
@ -30,7 +30,8 @@ source=("git+https://github.com/EdgeTX/edgetx.git#tag=v$pkgver"
|
|||
"git+https://github.com/FreeRTOS/FreeRTOS-Kernel-Partner-Supported-Ports.git"
|
||||
"git+https://github.com/EdgeTX/lvgl.git"
|
||||
"git+https://github.com/nothings/stb.git"
|
||||
install.patch)
|
||||
install.patch
|
||||
remove-ssl-check.patch)
|
||||
b2sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
|
@ -40,17 +41,16 @@ b2sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'2f2d110ba03c3d852bec93a0705570df93e72f5e3757bd64494083c5a1ae59c5228024fca563043c05014b1962ccde88e029a6bac2fe36be6e852a53b35a43fb')
|
||||
'2f2d110ba03c3d852bec93a0705570df93e72f5e3757bd64494083c5a1ae59c5228024fca563043c05014b1962ccde88e029a6bac2fe36be6e852a53b35a43fb'
|
||||
'6ad8cfff9f623c1d0182713839419b633f421e762d01cd46b2ce817c1552929d9ffadcb38f112d6ac9d3d196346b781d842ad0d9c34d4dbe0d5709a3edbc6026')
|
||||
|
||||
prepare() {
|
||||
export EDGETX_VERSION_TAG=$pkgver
|
||||
|
||||
cd $_pkgbase
|
||||
|
||||
# Revert this commit, as it installs all files from /usr/lib into this package.
|
||||
git revert e78da0e4d56a15e5fb9625852613ff0f0f3db25a --no-commit
|
||||
|
||||
patch ./tools/build-companion.sh < $srcdir/install.patch
|
||||
patch ./companion/src/CMakeLists.txt < $srcdir/remove-ssl-check.patch
|
||||
|
||||
cd $srcdir/$_pkgbase/companion/src/thirdparty/
|
||||
git submodule init
|
||||
|
|
25
remove-ssl-check.patch
Normal file
25
remove-ssl-check.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- CMakeLists.txt.old 2023-11-12 12:28:49.000000000 +0100
|
||||
+++ CMakeLists.txt 2023-11-16 17:08:59.841823856 +0100
|
||||
@@ -353,9 +353,6 @@
|
||||
cmake_policy(SET CMP0026 OLD) # https://cmake.org/cmake/help/v3.0/policy/CMP0026.html
|
||||
endif()
|
||||
|
||||
-# OpenSSL
|
||||
-include(FindOpenSSL)
|
||||
-
|
||||
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
message(STATUS "install " ${CMAKE_BINARY_DIR} " to " ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
install(TARGETS ${COMPANION_NAME} DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
@@ -379,12 +376,6 @@
|
||||
install(FILES ../targets/linux/45-companion-taranis.rules DESTINATION ${INSTALL_TEMP_LIB_PFX}lib/udev/rules.d RENAME 45-companion${C9X_NAME_SUFFIX}-taranis.rules)
|
||||
install(FILES ../targets/linux/45-usbasp.rules DESTINATION ${INSTALL_TEMP_LIB_PFX}lib/udev/rules.d RENAME 45-companion${C9X_NAME_SUFFIX}-usbasp.rules)
|
||||
|
||||
- if (OPENSSL_FOUND)
|
||||
- get_filename_component(OPENSSL_SSL_LIBRARY_DIR ${OPENSSL_SSL_LIBRARY} DIRECTORY)
|
||||
- # install only files Qt networking requires
|
||||
- install(DIRECTORY ${OPENSSL_SSL_LIBRARY_DIR}/ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib FILES_MATCHING PATTERN "engines*" EXCLUDE PATTERN "pkg*" EXCLUDE PATTERN "*.so*")
|
||||
- endif()
|
||||
-
|
||||
# Linux specific code
|
||||
set(OperatingSystem "Linux")
|
||||
# Shortcut target
|
Loading…
Reference in a new issue