upgrade to 2.8

This commit is contained in:
horstderheld 2022-11-29 21:28:32 +01:00
parent 029e38df80
commit aa0d869431
3 changed files with 36 additions and 25 deletions

View file

@ -1,6 +1,6 @@
pkgbase = edgetx-companion
pkgdesc = EEPROM Editor and Simulator for EdgeTX RC radio transmitter firmwares
pkgver = 2.7.1
pkgver = 2.8.0
pkgrel = 1
url = https://edgetx.org/
arch = x86_64
@ -17,6 +17,7 @@ pkgbase = edgetx-companion
makedepends = git
makedepends = icu
makedepends = python
makedepends = python-lz4
makedepends = python-pillow
makedepends = python-pyqt5
makedepends = qt5-svg
@ -25,15 +26,14 @@ pkgbase = edgetx-companion
makedepends = sed
makedepends = xsd
depends = hicolor-icon-theme
depends = qt5-base
depends = qt5-multimedia
depends = sdl
optdepends = dfu-util: tool for flashing stm32 based radios
provides = companion
conflicts = companion
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.7.1
source = git+https://github.com/EdgeTX/edgetx.git#tag=v2.8.0
source = install.patch
sha256sums = SKIP
sha256sums = f9b62f82f402ea96153a7e45ec22aeaa4780039d57b28cc8ca8456e05c34ffe7
sha256sums = efa51cbbff6cb466a6a9bd681b04b158fce6e48d2db4c5cc235c1a871037f6c8
pkgname = edgetx-companion

View file

@ -4,16 +4,16 @@
# Contributer: Arnaud
pkgname=edgetx-companion
pkgver=2.7.1
pkgver=2.8.0
pkgrel=1
pkgdesc="EEPROM Editor and Simulator for EdgeTX RC radio transmitter firmwares"
arch=('x86_64')
url='https://edgetx.org/'
license=('GPL2')
depends=('hicolor-icon-theme' 'qt5-base' 'qt5-multimedia' 'sdl')
depends=('hicolor-icon-theme' 'qt5-multimedia' 'sdl')
optdepends=('dfu-util: tool for flashing stm32 based radios')
makedepends=('arm-none-eabi-binutils' 'arm-none-eabi-gcc' 'arm-none-eabi-newlib'
'avr-gcc' 'avr-libc' 'bc' 'cmake' 'fox' 'gcc' 'git' 'icu' 'python'
'avr-gcc' 'avr-libc' 'bc' 'cmake' 'fox' 'gcc' 'git' 'icu' 'python' 'python-lz4'
'python-pillow' 'python-pyqt5' 'qt5-svg' 'qt5-tools' 'qt5-translations'
'sed' 'xsd')
provides=('companion')
@ -23,21 +23,21 @@ _versuff=${pkgver/./} && _versuff=${_versuff%%.*}
source=("git+https://github.com/EdgeTX/edgetx.git#tag=v${pkgver}"
install.patch)
sha256sums=('SKIP'
'f9b62f82f402ea96153a7e45ec22aeaa4780039d57b28cc8ca8456e05c34ffe7')
'efa51cbbff6cb466a6a9bd681b04b158fce6e48d2db4c5cc235c1a871037f6c8')
prepare() {
cd ${_pkgbase}
patch ./tools/build-companion-nightly.sh < ${srcdir}/install.patch
patch ./tools/build-companion.sh < ${srcdir}/install.patch
git submodule update --init --recursive
}
build() {
cd ${_pkgbase}
./tools/build-companion-nightly.sh ${MAKEFLAGS} ${srcdir}/${_pkgbase} ${srcdir}/build ${_versuff}
./tools/build-companion.sh ${MAKEFLAGS} ${srcdir}/${_pkgbase} ${srcdir}/build ${_versuff}
}
package() {
cd ${srcdir}/build
cd ${srcdir}/build/native
make DESTDIR=${pkgdir}/ install
cd ${pkgdir}/usr/share/applications
sed -i -e 's/Categories=Application/Categories=Utility/' companion${_versuff}.desktop

View file

@ -1,3 +1,5 @@
--- build-companion-org.sh 2022-11-29 15:37:49.493916416 +0100
+++ build-companion.sh 2022-11-29 20:11:06.425385270 +0100
@@ -30,7 +30,7 @@
SRCDIR=$1
OUTDIR=$2
@ -6,9 +8,9 @@
+COMMON_OPTIONS="-DCMAKE_INSTALL_PREFIX=/usr -DGVARS=YES -DHELI=YES -DLUA=YES -Wno-dev -DCMAKE_BUILD_TYPE=Release"
if [ "$(uname)" = "Darwin" ]; then
COMMON_OPTIONS="${COMMON_OPTIONS} -DCMAKE_OSX_DEPLOYMENT_TARGET='10.9'"
elif [ "$(uname)" != "Linux" ]; then
@@ -41,9 +41,9 @@
COMMON_OPTIONS="${COMMON_OPTIONS} -DVERSION_SUFFIX=$3"
elif [ "$(uname)" != "Linux" ]; then # Assume Windows and MSYS2
@@ -59,9 +59,9 @@
fi
fi
-rm -rf build
@ -18,19 +20,28 @@
+mkdir ${OUTDIR}
+cd ${OUTDIR}
cmake ${COMMON_OPTIONS} -DPCB=X9LITE ${SRCDIR}
make -j${JOBS} libsimulator
@@ -128,13 +128,3 @@
cmake ${COMMON_OPTIONS} -DPCB=X12S ${SRCDIR}
make -j${JOBS} libsimulator
declare -a simulator_plugins=(x9lite x9lites
x7 x7-access
@@ -161,19 +161,10 @@
esac
rm -f CMakeCache.txt native/CMakeCache.txt
+
cmake ${BUILD_OPTIONS} "${SRCDIR}"
cmake --build . --target native-configure
cmake --build native -j"${JOBS}" --target libsimulator
-done
+done
-cmake --build . --target native-configure
-if [ "$(uname)" = "Darwin" ]; then
- make -j${JOBS} package
- cp *.dmg ${OUTDIR}
- cmake --build native -j"${JOBS}" --target package
- cp native/*.dmg "${OUTDIR}"
-elif [ "$(uname)" = "Linux" ]; then
- make -j${JOBS} package
- cp *.AppImage ${OUTDIR}
- cmake --build native -j"${JOBS}" --target package
- cp native/*.AppImage "${OUTDIR}"
-else
- make installer
- cp companion/*.exe ${OUTDIR}
- cmake --build native --target installer
- cp native/companion/*.exe "${OUTDIR}"
-fi
+cmake ${BUILD_OPTIONS} "${OUTDIR}/native"