edgetx-companion/install.patch
2022-11-29 21:28:32 +01:00

47 lines
1.4 KiB
Diff

--- build-companion-org.sh 2022-11-29 15:37:49.493916416 +0100
+++ build-companion.sh 2022-11-29 20:11:06.425385270 +0100
@@ -30,7 +30,7 @@
SRCDIR=$1
OUTDIR=$2
-COMMON_OPTIONS="-DGVARS=YES -DHELI=YES -DLUA=YES -Wno-dev -DCMAKE_BUILD_TYPE=Release"
+COMMON_OPTIONS="-DCMAKE_INSTALL_PREFIX=/usr -DGVARS=YES -DHELI=YES -DLUA=YES -Wno-dev -DCMAKE_BUILD_TYPE=Release"
if [ "$(uname)" = "Darwin" ]; then
COMMON_OPTIONS="${COMMON_OPTIONS} -DCMAKE_OSX_DEPLOYMENT_TARGET='10.9'"
elif [ "$(uname)" != "Linux" ]; then # Assume Windows and MSYS2
@@ -59,9 +59,9 @@
fi
fi
-rm -rf build
-mkdir build
-cd build
+rm -rf ${OUTDIR}
+mkdir ${OUTDIR}
+cd ${OUTDIR}
declare -a simulator_plugins=(x9lite x9lites
x7 x7-access
@@ -161,19 +161,10 @@
esac
rm -f CMakeCache.txt native/CMakeCache.txt
+
cmake ${BUILD_OPTIONS} "${SRCDIR}"
cmake --build . --target native-configure
cmake --build native -j"${JOBS}" --target libsimulator
-done
+done
-cmake --build . --target native-configure
-if [ "$(uname)" = "Darwin" ]; then
- cmake --build native -j"${JOBS}" --target package
- cp native/*.dmg "${OUTDIR}"
-elif [ "$(uname)" = "Linux" ]; then
- cmake --build native -j"${JOBS}" --target package
- cp native/*.AppImage "${OUTDIR}"
-else
- cmake --build native --target installer
- cp native/companion/*.exe "${OUTDIR}"
-fi
+cmake ${BUILD_OPTIONS} "${OUTDIR}/native"